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Limited Warranty

ALL WARRANTIES (INCLUDING ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR 
ANY PARTICULAR PURPOSE) ARE EXPRESSLY EXCLUDED.  THIS SOFTWARE AND ALL 
PROGRAM FILES ARE PROVIDED "AS IS" AND THE USER MUST ASSUME THE ENTIRE RISK 
OF USING THIS PROGRAM.

TRIAL USE (SHAREWARE EVALUATION VERSION) WARRANTY
The Shareware evaluation (trial use) version of Stable Data Asisstant is provided "AS IS".
WINTERRA (tm) Software Group makes no warranties of any kind, expressed or implied, that this 
program is error free or that any supplied data or other program information is accurate or complete.  
No representation or warranties are made as to the completeness, accuracy, or precision of this 
program.

REGISTERED VERSION
WINTERRA (tm) Software Group warrants that physical diskette(s) and physical documentation 
provided with SOFTWARE to be free of defects in materials and workmanship for a period of 90 days 
from the date of registration.  If WINTERRA Software Group receives notification within the warranty 
period of defects in materials or workmanship, and such notification is determined by WINTERRA 
Software Group to be correct, WINTERRA Software Group will replace the defective diskette(s) or 
documentation.

The entire and exclusive liability and remedy for breach of this Limited Warranty shall be limited to the
replacement of defective diskette(s) or documentation and shall not include or extend to any claim for 
or right to recover any other damages, including but not limited to, loss of profits or other trading 
losses incurred as a result of any decision or action taken on your part based upon information 
provided, implied, or suggested by the SOFTWARE, loss of data, loss of use of the SOFTWARE, or 
any other special, incidental, or consequential damages or other similar claims, even if WINTERRA 
Software Group has been specifically advised of the possibility of such damages.  In no event will 
WINTERRA Software Group's liability for any damages to you or any other person ever exceed the 
lower of the suggested list price or actual price paid for the license to use the software, regardless of 
any form of the claim.  Some states do not allow limitations on the duration of the implied warranty, so
the above limitation may not apply to you.



Association of Shareware Professionals
Ombudsman Statement

This program is produced by a member of the Association of Shareware Professionals 
(ASP).  ASP wants to make sure that the shareware principle works for you.  If you are 
unable to resolve a shareware-related problem with an ASP member by contacting the 
member directly, ASP may be able to help.  The ASP Ombudsman can help you resolve a 
dispute or problem with an ASP member, but does not provide technical support for  
members' products.  Please write to the ASP Ombudsman at 545 Grover Road, Muskegon, 
MI 49442-9427  or  send a CompuServe message via CompuServe Mail to ASP 
Ombudsman 72050,1433.

The OMB may also be contacted by FAX by sending to the ASP FAX number: (616) 788-
2765.  In communication with the OMB please include a telephone number and/or FAX if 
available.

This "Shareware Evaluation" copy of Stable - Data Assistant is a completely
functional program and all program functions have been documented.

This is not a "demo" program.
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The following lists the major sections contained within this document.

1. Software License Agreement and Registration Benefits
Information on the limited license agreement and benefits you will receive when you 
register the product.

2. Introduction
Overview of the product; briefly describing the major functions and features provided 
by the program.

3. Installation
Information is provided identifying the shareware distribution file set and basic 
installation notes.

4. Configuration
The section guides you to the areas of the program that must be configured before 
you initially use the product.

5. Main Window
Summarizes the Main program window by describing its functionality and identifying 
the available menu selections.

6. File Maintenance Window
Summarizes the File Maintenance window by describing its functionality and 
identifying the available menu selections.

7. Terminal Window
Summarizes the Terminal window by describing its functionality and identifying the 
available menu selections.

8. Procedures
This section summarizes many of the important features and procedures you will be 
using in Stable Data Assistant.

9. Financial ASCII Data File Format
The ASCII financial file format is described in this section.  The information contained
in this section also relates to Stable - Technical Graphs v1.11 and above.

10. Registration Order Form
Order form for registering the product.



1. Software License Agreement and Registration Benefits

Stable Investment Software - Data Assistant is a copyrighted product protected by copyright 
law.  You are authorized to use this copy of Stable Data Assistant for a period of 30 days for 
your own personal evaluation.  You may also distribute copies of this evaluation version to 
friends and associates - so long as all conditions identified in the LICENSE.DOC text file are
met.

User Groups, Computer Clubs, Disk Vendors and Distributors, Subscription Services, 
Disk-of-the-Month Clubs, etc., should refer to the VENDOR.DOC file for complete 
information relating to them.

BBS SYSOPs should refer to the SYSOP.DOC file for complete information relating to them.

To become a licensed user of Stable - Data Assistant, simply fill out and return the supplied 
registration form along with your registration payment.  The registration form can be found at
the end of this document, in the On-line Help, or you can use the form found in the file 
REGISTER.DOC.

Registration Benefits
As a registered user, you will receive a personalized copy of the latest Stable - Data 
Assistant product on either 5 1/4 or 3 1/2 inch diskette.  Your registered copy is personalized
with your name and a unique license number that - unlike the evaluation version of the 
product - will be licensed for one single user and cannot be distributed.

Additionally, as a registered user you will:

o Receive a laser-printed User's Manual for the product.
o Receive an offer for a free Introductory Membership to CompuServe (including a $15

Usage Credit).
o Be notified of all new major product releases.  As a licensed user you will be offered 

major version releases at a substantially reduced and favorable rate.
o Receive technical support by phone, mail, or electronic mail via CompuServe.



2. Introduction

Stable Data Assistant is a Microsoft Windows 3.1 product providing a wide range of features
specific to the managment and retrieval of financial ASCII data.  While Stable Data Assistant
has been developed as a companion product to our Stable Technical Graphs program, it can
also be used in most other environments where ASCII data files are used for financial data 
storage.

Both daily and historical financial data are managed and processed by Stable Data 
Assistant.

On a daily basis, you can update your financial data either manually or automatically via 
CompuServe's BASICQUOTES data service.  This service area was selected primarily to 
take advantage of the Basic Services membership plan.

Additionally, you have the ability to retreive historical financial data for a multitude of 
financial items available on CompuServe.  Historical data retrieval is performed through the 
MicroQuote area using specifically the MQINT 200 interface.

For costs associated with the retrieval of financial data from CompuServe - 
check your membership information or contact CompuServe Customer 
Support.

Here are some of the features found in Stable Data Assistant:

Manual Data Update is supported through dialog box prompting.  This alleviates the 
need to write special programs that update your ASCII data files - or to manually edit 
your files using a text editor.  After establishing the financial symbols and associated 
data files you want to maintain, Data Assistant prompts you for the daily figures and 
automatically updates your ASCII data files.

Automated Data Update is performed using the CompuServe data service.  By far the 
most important feature of Data Assistant, automated data update saves you time and 
money every day.  Data Assistant establishs communications with CompuServe, 
retrieves your financial data, logs off from CompuServe, and updates your ASCII 
financial data - all automatically and conveniently.

Data File Maintenance provides you with a wide variety of data maintenance functions 
for managing your historical ASCII data files.  With this capability, you can:

1. Create new ASCII data files.
2. Modify the contents and format of your existing ASCII data files.
3. Merge several ASCII data files together into one file.
4. Perform data verification on your ASCII data files.
5. Adjust your ASCII data files for splits and dividends.

Script File Processing for automating communication sessions with remote systems 
via the modem is also available through a communications terminal.  This feature is how 
Stable Data Assistant performs automated retrieval.  You too can take advantage of this 
processing feature by writing your own communication scripts for almost any personal 
need or requirement.





3. Installation
Before you actually begin using Stable Data Assistant, it is strongly suggested that you at 
least perform the following task:

!BACKUP YOUR DISTRIBUTION FILES OR DISKETTE!

Accidents do happen!  While there may not be any way to prevent the loss of your program, 
you can take action now to help avoid the problem of being without it in the future.  Making a
backup copy now is insurance that you won't have to be without Stable Data Assistant when 
you need it.

Product Distribution Files

DASST.EXE Stable - Data Assistant Windows Program File
DASST.HLP Stable - Data Assistant Windows Help File
DASST.WRI Stable - Data Assistant Shareware Reference
DASST.INI Initial .INI file

FILE_ID.DIZ Product description for BBS distribution

DAILY.TPL Template for daily quote script build
HISTORY.TPL Template for historical retrieval script build

DJ30.CSV Sample ASCII data - Dow Jones Industrials
SP500.CSV Sample ASCII data - S&P 500
HRB.CSV Sample ASCII data - H&R Block

BILLING.SCR Sample script file for CompuServe access

CTL3D.DLL Required DLL for 3-D dialog support
COMMDLG.DLL Required DLL for common Windows dialogs

README.DOC Important last-minute information.
REGISTER.DOC Registration information and order form.
PACKING.LSTShareware distribution file list.
VENDOR.DOC Information and restrictions for disk vendors,
SYSOP.DOC Information for Bulletin Board System distribution.
DESCRIBE.DOC Sample descriptions for catalogs, BBSs, etc.
LICENSE.DOC Individual User License and Usage Information
SITELICE.DOC Site License Information and Agreement.

Stable Data Assistant requires the following minimum set of distribution files to run 
successfully:

DASST.EXE
DASST.HLP
DASST.INI
DAILY.TPL
HISTORY.TPL
COMMDLG.DLL



CTL3D.DLL

When executing Stable Data Assistant, all of the above files MUST BE available at runtime; 
either from the directory where DASST.EXE resides - or a directory found in your 
AUTOEXEC.BAT "PATH=" statement.

To simplify the process of running Stable Data Assistant within your Windows 3.1 
environment, the DOS directory that you choose to store the product files should be one that
contains ALL the files distributed with Data Assistant. We recommend placing all the 
distribution files in a directory named "\DASST" from the root.  The data files that have 
been provided with the product allow you to immediately use the program in your own 
environment.

If you have a compressed copy of the Stable Data Assistant package (ie, DASST.ZIP, 
DASST.ARC, DASST.LHZ), the simplest installation procedure is:

1. Create a new subdirectory on your system called "\DASST".
2. Copy the compressed Data Assistant file into this new directory.
3. Decompress the file using the appropriate decompression program (PKUNZIP.EXE 

for .ZIP file, PKXARC.EXE for .ARC, etc.)

If you have received the Stable Data Assistant package as the complete set of 
uncompressed individual files, simply create the "\DASST" directory and copy ALL of the 
files into this directory.

If you try and run Stable Data Assistant and encounter a Windows error message similar to 
the following...

File Error
CANNOT FIND CTL3D.DLL

...this indicates you have an invalid installation of Data Assistant on your computer.  If you 
installed all of the Data Assistant distribution files into a single directory, check to make sure 
that CTL3D.DLL is in that directory.



4. Configuration
As the first step in using Stable Data Assistant, you must configure the program for use with 
your particular financial ASCII data, your choice of data update, and communications 
environment.  All of the following items should either be configured or confirmed to be 
correct before you use Data Assistant for automatic data retrieval.

From the Main window, select the Configure menu.  Within this menu are several selections 
you can chose from for configuring the program:

Daily Symbols...
This is where you identify all of your financial symbols and their respective ASCII data 
files to Data Assistant.  The items in this list are key to the correct operation of Data 
Assistant.  The list of symbols is used for all daily update operations - whether 
automated or manual.

The HRB financial symbol (H&R Block) can be used to become familiar with the 
process of retrieving financial quotes from CompuServe.  CompuServe does not 
charge for daily or historical quotes using this symbol.

Data Access...
This selection allows you to indicate the type of daily and historical data access methods
you will be using within the product.

If you will be performing manual daily update - select the None button.  If you will be 
using CompuServe for your daily update process, choose the CompuServe 
BASICQUOTES button and entter the required information.  If you will be writing and 
using your own communications script for retrieving daily financial data - select User 
Script and provide the requested information (Data Assistant is not able to automatically 
update your data files if you use your own script).

Historical data access selection is similar to the daily selection process.



Modem...
Allows you to specify the actual command strings used with your modem for remote 
communications.  Stable Data Assistant is shipped with a default set of commonly used 
command strings (Hayes-compatible).

The special character '~' can be used is used to represent a delay of approximately 1 
second in a modem command string.

Initialization:
Enter the command string you commonly use to initialize your modem.  This string will 
automatically be issued to the modem each time a connection is made.

Dial Prefix:
Enter the command string used to prefix the phone number when dialing out through the 
modem.  The default "ATDT" represents dialing the telephone in originate mode using 
touch-tone phone.

Connect:
This is the response string received from the modem when an external connection has 
been made.  Typically you receive the baud rate in addition to this string - though 
instructing Data Assistant to key on the "CONNECT" text is much more flexible.

Disconnect:
This is the command string you send to the modem when you want to physically break 
the connection with a remote system.  Normally, you will allow Data Assistant to control 
all automated activities.

This command string defaults to getting the modem's attention ("+++"), waiting 
approximately 2 seconds ("~~"), resetting the modem and hanging up the phone line 
("AT&FZH").

Command OK:
This is the ASCII response from the modem when it recognizes and successfully 
executes a command.

Command Error, No Carrier, Busy, No Dial Tone:
These are self-explanatory and represent the ASCII response from the modem when 
one of these conditions occur.

Script Editor...
This selection allows you to specify the name of a program you want to use for editing ASCII
script files from within Data Assistant.



5. Main Window

The Main window of Stable Data Assistant provides access to all areas of the product.  From
this window, you are able to configure the product for use, maintain your historical ASCII 
data files, initiate automated daily and historical data retrieval, perform manual data update, 
and request product help.

File menu

File Maintenance...

Displays a dialog box for performing file maintenance functions specific to your historical 
ASCII data.

Exit
Exits the program.

Update menu

Daily...

Executes your pre-selected method for daily data retrieval; which is either the automated
CompuServe BASICQUOTES access, or the execution of a selected communications 
script file.

Historical...

Allows you to retrieve historical quotes by executing either the automated CompuServe 
MQINT access process, or by executing a selected communications script file.

Manual...

Allows you to manually update your ASCII historical data based on a pre-selected list of 
symbols.



Configure menu

Daily Symbols...
Allows you to specify the list of financial symbols used for both the automated 
CompuServe daily update and manual daily update processes.

Data Access...
Allows you to select and configure the daily and historical data access methods that you 
will use.

Modem...
Allows you to specify modem-specific control strings used by Data Assistant for 
communications control.

Script Editor...
Allows you to specify the name of the program you would like to use for editing your 
script files.

Terminal menu

Terminal!

Executes the Terminal communications window.

Help menu

Index
Displays the help index for Stable Data Assistant.

Commands
Displays the first command topic for Stable Data Assistant.

Procedures
Displays the first procedure topic for Stable Data Assistant.

Registration Info
Allows you to print a product registration form to your system printer for becoming a 
registered user of Stable Data Assistant.

Remember, this copyrighted product is being distributed via the shareware 
marketing process for your evaluation only - and is not free software.  You are 
required to purchase the product if you continue to use it past the thirty day 
evaluation period.

About Data Assistant



Provides product, company, and registration status information.



6. File Maintenance Window

The File Maintenance window allows you to perform a wide variety of data maintenance 
functions on your historical ASCII data files.  Through this window you are able to:

* Create new ASCII data files.
* Modify the contents and format of existing ASCII data files.
* Merge several ASCII files together as one.
* Make adjustments for splits and dividends.
* Perform data verification.

File menu

New
This selection is used to create a new ASCII data file.

Open...
Opens an existing ASCII data file for performing maintenance operations.

Save
Saves the current working file to disk.

Save As...
Saves the current working file to a different file name.

Merge...
Allows you to merge the contents of another ASCII data file into the current working file.

Exit
Exits the File Maintenance window and returns to the Main window.

Edit menu

Adjust...
Allows you to make adjustments to the current working file specific to splits and 
dividends.

Verify
Allows you to perform data verification on the current working file.



7. Terminal Window

The Terminal window provides data communications functionality for retrieving daily and 
historical financial data.  Additionally, the Terminal window provides ASCII script file 
processing and data capture functionality extending its use beyond just data retrieval.

Control menu

Connect
Opens a communication connection between your computer and the modem - based on 
the current communications settings and port selection.

Disconnect
Breaks the communication connection between your computer and the modem.

Capture
Allows you to toggle on and off the capturing of ASCII data coming across the 
communications line.  Only data received from the modem is saved to the file.

Hang Up
Forces the modem to hang itself up and to break its connection with an external or 
remote modem.  This does not perform a full disconnect.

Exit
Exits the Terminal window and returns to the Main window.

Script menu

Load Script...
Allows you to load a selected ASCII script file for processing by the Terminal window.

Execute
Executes the current script file.  This function can also be used to step through script file 
instructions if the automated processing of the script fails.

Cancel
Cancels and aborts execution of the current script.

Edit Script...
Allows you to edit a selected ASCII script file using your pre-selected text editor.

Configure menu

Communications...
Allows you specify the communications parameters and port for the current terminal 
session.

Font...
Allows you to select the font size and color for text displayed in the terminal window.



Script Editor...
Allows you to specify the name of the program you would like to use for editing your 
script files.



8. Procedures

The following pages describe many of the commonly used procedures of Stable Data 
Assistant.



Adjusting Data for Splits and Dividends

Occasional adjustments will need to be made to your financial data in order to smooth out 
marketplace factors such as stock splits and dividends.  If raw data is not adjusted in some 
manner for these events, applying technical analysis against this data would reflect improper
results.  Stable Data Assistant provides you the means for actually adjusting your financial 
data whenever necessary.

Any adjustments you make to your data files become permanent once you save your
file following the adjustment.  If you want to maintain unadjusted prices in your data 
files, DO NOT PERFORM THIS FUNCTION.

Adjustment Factor
The adjustment factor is a value used to physically adjust your financial data so that all data 
maintains the appropriate value relationship within the file.  When making adjustments, 
Stable Data Assistant multiplies volume data - and divides all price data - by the specified 
adjustment factor.

Stock Splits
When a stock split occurs, you should adjust all data prior to the split by an adjustment 
factor represented by the following calculation:

Shares held after the split / Shares held before the split

For example, the adjustment factor of a 2 for 1 stock split would be represented by the 
value 2 (holding twice as many shares following the split or 2/1); a 3 for 1 split would be 
represented by an adjustment factor of 3 (3/1).

Cash Dividends and Capital Gains Distributions
Some stocks offer dividends - while mutual funds typically distribute dividends from net 
investment income as well as distributions from realized net capital gains.  The 
calculation used for the adjustment factor for these types of events is:

Previous day's close / ( Previous day's close - Distribution)

For example, assume a mutual fund distributes an annual dividend of $.09 and a capital 
gain distribution of $1.20.  Yesterday's close was 24.58 (today's close has already been 
adjusted for the distributions).  The proper adjustment factor is 1.055388579 (24.58 / 
(24.58 - 1.29)).

To adjust your existing data:
1. Select File Maintenance... from the File menu on the Main window.
2. Load the financial data you want to adjust by selecting Open... from the File menu.
3. Select Adjust... from the Edit menu or choose the Split/Div Adjust... button.
4. Select the adjustment type from the provided options.

If you need to make an adjustmment not related to the standard adjustment types, 
select Adjustment Factor Entry.  This will allow you to enter your own adjustment 
factor.

5. Enter the date range for the data you want to make adjustments to.



HINT: Entering a date prior to the first actual record will automatically select the first 
record.

6. Enter the appropriate values for your selected adjustment type.  The adjustment 
factor is automatically calculated and displayed for you.

7. Choose the Adjust Data! button to adjust the data.

Only the data in the list box is adjusted at this point.  To save the adjusted data to 
your file, select Save from the File menu.



Configure for CompuServe Access

In order for Stable Data Assistant to properly retrieve daily and historical quotes from 
CompuServe, information must be available for connecting to, and controlling, the 
communication session.  In addition to the financial symbols you will be tracking, Data 
Assistant requires the following additional information:

1. The phone number you use to access CompuServe.
2. Your CompuServe user id.
3. Your CompuServe password.
4. The communication parameters for accessing CompuServe.

To configure your system for daily and/or historical CompuServe access:
1. Select Data Access... from the Configure menu on the main window and choose 

either the CompuServe BASICQUOTES or the CompuServe MQINT 200 buttons.  
You must configure each of BASICQUOTES and MQINT 200 access individually.

2. Enter your CompuServe network access phone number for your area and modem 
baud rate.

3. Enter your CompuServe user id.
4. Enter your CompuServe password.
5. Select the appropriate communication port, baud rate, data bits, parity, and stop bits 

for communication.  Local echo should be off.
6. Enter the full path and name of the file that will be used to store the captured 

CompuServe session information.
7. Select "Confirm Data Update?" if you would like to confirm each symbol's update.  It 

is highly suggested that you select this option.  If an error occurs during the 
transmission, you can avoid updating your data with invalid data if you confirm each 
daily update.

8. Select "Save Session Files?" if you would like Data Assistant to make a copy of each
captured session's information.

File copies of each session are given unique names based on the time of the 
capture.  Each file is named "YYMMDDHH.MMx" where; YY is the year, MM the 
month, DD the day, HH the hour, and MM the minute.  "x" is either a 'D' for a daily 
capture, or an 'H' for historical.

9. Choose the OK button to store your entered information.



Creating New Data Files

New ASCII data files can be created using Stable Data Assistant through use of the File 
Maintenance dialog or the Daily/History Symbol dialogs.

To create a new ASCII data file using the File Maintenance dialog:
1. Select File Maintenance... from the File menu, or choose the Maintenance button on 

the main window.
2. Select New from the File menu of the File Maintenance dialog.  This clears the 

contents of the maintenance window and sets the default values for the new file.
3. Enter new data into the file using the data edit fields above the data list box.
4. Select Save As... from the File menu to save your new data file.

To create new data files in the Daily or History Symbols dialogs:
* You can enter a file name that does not exist when inserting new symbols into either 

the Daily or History Symbol dialog.  When you choose the Insert button, Data 
Assistant will notify you that the file must first be created - and allow you to create it 
yourself later, or it can automatically be created at that time.



Historical Data Retrieval

Stable Data Assistant supports both an automated and manual method for gathering 
historical financial data.  Automated data retrieval is performed by retrieving historical quotes
using the MQINT facilities on CompuServe for accessing the MicroQuote, Quick Quote, and 
Commodity databases.

You have three choices for retrieving or updating existing financial data with historical 
information:

Manual
Data Assistant provides a prompted method for you to update your symbols through use 
of the File Maintenance facilities.

Script File
If you have a source other than CompuServe for retrieving financial data, you can make 
use of the script processing capabilities found in Data Assistant.  The script file 
processing language allows you to dial, connect, capture, and execute a specific set of 
instructions for automating the interaction between you and the remote site.
While allowing you to automate the retrieval process using scripts, Data Assistant does 
not automatically process the retrieved information to update your data files.

Fully Automated (using CompuServe)
The fully automated process allows you to dial up, connect, download, and update your 
daily financial files automatically from CompuServe.  Only symbols contained in your 
Historical Symbol list are retrieved for update.

To select your method of historical retrieval and update:
* Select Data Access... from the Configure menu on the main window and choose 

from one of the provided access methods for historical retrieval and update.

To perform automated or scripted historical update:
1. Select Historical Data Retrieval... from the Data menu, or choose the Historical 

button on the main window.
2. Enter complete information for each symbol you want to retrieve historical data for in 

the History Symbols dialog box (See Maintaining Your Daily Financial Symbols for a 
description on entering new symbol names into Data Assistant).

3. Identify the data frequency and indicate the data selection range for retrieval in the 
Historical Data Retrieval dialog box.

4. Choose the Retrieve Quotes! button in the Historical Data Retrieval dialog box.

To perform manual historical update:
1. Select File Maintenance... from the File menu, or choose the Maintenance button on 

the main window.
2. Select the file you want to update by selecting Open... from the File menu of the File 

Maintenance dialog box.



Maintaining Your Daily Financial Symbols

Regardless of whether you are using Stable Data Assistant for automated daily quote 
retrieval from CompuServe, or for manually updating your data, you must indicate the 
"stable" of financial symbols you want to track.

On the Configure menu located on the Main window, select Daily Symbols... to display the 
Daily Symbol list dialog box.  From this dialog you can perform such actions as:

* Adding new symbols to your daily symbol list.
* Modifying existing symbol information.
* Deleting symbols from your daily symbol list.

The information you enter for each symbol you are maintaining is key to the
successful operation of Stable Data Assistant.

Symbol
This must be the actual symbol name used by the CompuServe BASICQUOTES 
database.  If you are maintaining your data through the manual update feature, this 
symbol can be any name - though you are encouraged to use common naming 
conventions.

CompuServe sells a Financial Services manual containing many of the symbols found in
their databases - including symbols for stocks, mutual funds, market indexes, and 
options.

The HRB financial symbol (H&R Block) can be used to become familiar with the process
of retrieving financial quotes from CompuServe.  CompuServe does not charge for daily 
or historical price quotes using this symbol.

Description
This is a descriptive name for the symbol.  It can be any text you want for describing the 
symbol.  This description is displayed for informational purposes at various points within 
the program.

File Name
The actual file name on disk for storing the data.  This name should include the full file 
specification - including the qualified drive and directory information:

Example:
C:\STABLE\DATA\HRB.CSV

To add (insert) a new symbol into your list:
1. Select the point within your list of symbols where you want to add or insert the new 

symbol (the "-new-" entry represents the end of the list).  If you selected an existing 
symbol as the point for inserting the new symbol, the selected symbol's information 
is displayed in the edit fields above the list box.

2. Enter the Symbol, Description, and File Name for the new symbol in the edit fields - 
overwriting any existing information.  If the file name does not exist, you are asked if 
you want the file automatically created for you.

3. Choose the Insert button to add your new symbol to the list.
4. Choose the OK button to update your changes to the list.



To change information on an existing symbol in your list:
1. Select the symbol you want to change from the list of symbols displayed in the list 

box.  The selected symbol's information is displayed in the edit fields above the list 
box.

2. Make the desired changes to the information in the edit fields.
3. Choose the Change button to change the data in the list.
4. Choose the OK button to update your changes to the list.

To delete a symbol from your list:
1. Select the symbol you want to delete from the list of symbols displayed in the list 

box.  The selected symbol's information is displayed in the edit fields above the list 
box.

2. Choose the Delete button to remove the symbol from your list.
3. Choose the OK button to update your changes to the list.



Maintaining Your Financial Data Files

The File Maintenance window allows you to perform a wide variety of data maintenance 
functions on your historical ASCII data files.  Through this window you are able to:

o Create new ASCII data files.
o Modify the contents and format of existing ASCII data files.
o Merge several ASCII files together as one.
o Perform data verification.
o Make adjustments for splits and dividends.

To access the ASCII file maintenance functions of Stable Data Assistant, select File 
Maintenance... from the File menu, or choose the Maintenance button on the main window.

To create a new ASCII data file:
1. Select New from the File menu of the File Maintenance dialog.  This clears the 

contents of the maintenance window and sets the default values for the new file.
2. Enter new data into the file using the data edit fields above the data list box.
3. Select Save As... from the File menu to save your new data file.

To modify the contents of an existing ASCII data file:
1. Select Open... from the File menu of the File Maintenance dialog and select the file 

you want to edit from the Open dialog box.
2. Make any desired changes, additions, or deletions from the file using the functionality

available in the maintenance window.
3. Select Save from the File menu to save your modified data file.

To modify the format of an existing ASCII data file:
1. Select Open... from the File menu of the File Maintenance dialog and select the file 

you want to edit from the Open dialog box.
2. Make any changes to the date format, data frequency, or data sequence of the ASCII

data file.
If a change to any of these items is made, Data Assistant enables the Apply 
Changes! button.

3. Choose the Apply Changes! button to modify the structure of the data file.
4. Select Save or Save As...from the File menu to save the modified ASCII data file.

To merge the contents of one ASCII data file into another:
1. Select Open... from the File menu of the File Maintenance dialog and select the file 

you want to load from the Open dialog box.
2. Select Merge... from the File menu or choose the Merge... button and select the file 

you want to merge from the Merge dialog box.
The maintenance window now contains the sorted data contents of both ASCII files, 
formatted against the first data file.

3. Select Save or Save As...from the File menu to save the merged ASCII data 
contents.

To verify the contents of an ASCII data file:
1. Select Open... from the File menu of the File Maintenance dialog and select the file 

you want to load from the Open dialog box.
2. Select Verify from the Edit menu or choose the Verify button to begin the data 

verification process.



If an error is found in your data, Data Assistant will describe the error and allow you 
to make the necessary changes through the edit fields.  Repeat step 2 until the 
verification completes without errors.

3. Select Save from the File menu to save your verified data file.

To make split/dividend adjustments to an ASCII data file:
1. Select Open... from the File menu of the File Maintenance dialog and select the file 

you want to load from the Open dialog box.
2. Select Adjust... from the Edit menu or choose the Split/Div Adjust... button.
3. Enter the date range and adjustment factor for the data that is to be modified.  

Choose the Adjust Data! button to update the data in the list box.
3. Select Save from the File menu to save your adjusted data file.



Selecting Your Data Retrieval Method

Stable Data Assistant supports both an automated and manual method for updating your 
daily or historical financial data.  Automated daily data retrieval is performed by retrieving 
daily quote information from the BASICQUOTES (Quick Quote) database on CompuServe, 
or for historical data retrieval, using the MQINT facilities on CompuServe for accessing the 
MicroQuote, Quick Quote, and Commodity databases.

You have three choices for updating your financial data using Stable Data Assistant:

Manual (Daily Retrieval)
Data Assistant provides a prompted method for you to update your symbols.  You are 
prompted for the daily information for each symbol contained in your daily symbol list.

Manual (Historical Retrieval)
Data Assistant provides a prompted method for you to update your symbols through use 
of the File Maintenance facilities.

Script File
If you have a source other than CompuServe for retrieving financial data, you can make 
use of the script processing capabilities found in Data Assistant.  The script file 
processing language allows you to dial, connect, capture, and execute a specific set of 
instructions for automating the interaction between you and the remote site.
While allowing you to automate the retrieval process using scripts, Data Assistant does 
not automatically process the retrieved information to update your data files.

Fully Automated (through CompuServe)
The fully automated process allows you to dial up, connect, download, and update your 
daily financial files automatically from CompuServe.  Only symbols contained in your 
Daily Symbol list (or History symbol list) are retrieved for update.

To select your method of daily retrieval and update:
* Select Data Access... from the Configure menu on the main window and choose 

from one of the provided access methods.



Updating Your Financial Data

Stable Data Assistant supports both an automated and manual method for updating your 
daily financial data.  Automated data retrieval is performed by retrieving daily quote 
information from the BASICQUOTES (Quick Quote) database on CompuServe (historical 
data retrieval is performed using the MQINT facilities on CompuServe).

You have three choices for updating your financial data on a daily basis:

Manual
Data Assistant provides a prompted method for you to update your symbols.  You are 
prompted for the daily information for each symbol contained in your daily symbol list.

Script File
If you have a source other than CompuServe for retrieving financial data, you can make 
use of the script processing capabilities found in Data Assistant.  The script file 
processing language allows you to dial, connect, capture, and execute a specific set of 
instructions for automating the interaction between you and the remote site.
While allowing you to automate the retrieval process using scripts, Data Assistant does 
not automatically process the retrieved information to update your data files.

Fully Automated (using CompuServe)
The fully automated process allows you to dial up, connect, download, and update your 
daily financial files automatically from CompuServe.  Only symbols contained in your 
Daily Symbol list are retrieved for update.

To select your method of daily retrieval and update:
* Select Data Access... from the Configure menu on the main window and choose 

from one of the provided access methods.

To perform automated or scripted daily update:
* Select Daily Update! from the Data menu, or choose the Daily Update button on the 

main window.

NOTE: If you specified a daily access method of "None", selecting the Daily Update 
menu or button will execute the manual daily update process automatically for you.

To perform manual daily update:
* Select Manual Daily Update... from the Data menu, or choose the Manual button on 

the main window.

NOTE: If you specified a daily access method of "None", selecting the Daily Update 
menu or button will execute the manual daily update process automatically for you.



About Script Files

Script files are ASCII command files specifically used for controlling interactive 
communications processes with remote computer systems.  The contents of a script file are 
coded command instructions which are processed sequentially by Stable Data Assistant in 
order to carry out a particular communication session.

Stable Data Assistant supports most of the instructions defined in the TAPCIS 
Access Program produced by Support Group, Inc. - along with a few additional 
commands specific to Data Assistant.  As a result, most script files that run using 
TAPCIS can also be processed successfully by Data Assistant.

Stable Data Assistant uses script files for all of its communications - including automated 
daily and historical quote retrieval and update via CompuServe.  You are also free to take 
advantage of the script file processing features of Data Assistant for any other personal use 
by using the Terminal window provided by the program.



Creating and Editing Script Files

Stable Data Assistant does not directly provide the functionality for creating and editing 
script files.  Normally, you will create your script files using an ASCII text editor such as 
Notepad or other favorite program.

Data Assistant does, however, allow you to execute your script file editor from within the 
program via a menu selection.  See Selecting Your Script File Editor.

Once you have identified a script file editor, you can execute the editor anytime from within 
either the Main window or Terminal window.

To create or edit a script file:
1. Select Terminal! from the Main window menu or choose the Terminal button to 

execute the Terminal window.
2. Select Edit Script... from the Script menu in the Terminal window.
2. Enter the name of a new script file or select an existing script file from the Edit Script 

dialog box and choose the OK button.
Your selected script file editor is executed with the name of the file you selected.



Daily/Historical Update Using Script Files

If you have chosen to use your own script file for retrieving daily or historical quotes, Data 
Assistant will automatically execute and process your script file for you.  However, Data 
Assistant will not update your ASCII financial data files with any information captured 
through your script.

To select the script file method for daily or historical retrieval:
1. Select Data Access... from the Configure menu on the main window and choose the 

User Script button for daily or historical access.
2. Enter the name of an existing script file in the appropriate field.

To perform daily retrieval:
* Select Daily Update! from the Data menu, or choose the Daily Update button on the 

main window.

To perform historical retrieval:
* Select Historical Data Retrieval... from the Data menu, or choose the Historical 

button on the main window.



Modifying Retrieval Templates

Stable Data Assistant uses script template files for building the appropriate script files used 
in performing automatic daily and historical data retrieval.  The daily template is named 
DAILY.TPL while the historical retrieval template is named HISTORY.TPL.

The templates provided with the product can be used by those users connecting to 
CompuServe through local access phone numbers.  In the event a proper connection 
cannot be established using these templates, you can perform limited editing of these 
templates in order to coordinate with other access procedures.



Running Your Own Script File

You can take advantage of the script processing functionality found in Stable Data Assistant 
by using the Terminal window.

To execute or run your own script file:
1. Select Terminal! from the Main window menu or choose the Terminal button to 

execute the Terminal window.
2. Turn on your modem and establish a connection by selecting Connect from the 

Control menu or choosing the Connect button.
3. Set the proper communications parameters for the remote site by selecting 

Communications... from the Configure menu.
4. Select Load... from the Script menu or choose the Load... button to load a script.
5. Use the Load Script dialog to select the script file you want to load for processing.
6. Select Execute from the Script menu or choose the Execute! button to begin 

processing the script.

If you find that the communications session is not progressing in a normal fashion, you can 
press the Execute! button to single step the script's instructions.  Use the Hang Up button if 
you need a quick method for terminating a connection.



Script File Command Reference

Script files are ASCII command files specifically used for controlling interactive 
communications processes with remote computer systems.  The contents of a script file are 
coded command instructions which are processed sequentially by Stable Data Assistant in 
order to carry out a particular communication session.

Each line of the script file contains either a comment, or an instruction which Data Assistant 
will process and execute during the communication session.  The first item of each line 
identifies the command or action that Data Assistant will perform.  Depending on the type of 
command, additional information will follow on the same line.

The following is the list of commands that Stable Data Assistant can process in your 
communication script files.  Each command has an associated shorthand identifier '[x]' that 
can be used in place of the full command name.

This command set encompasses most of the instructions used by the TAPCIS Access 
Program produced by Support Group, Inc. - along with a few additional commands.  As 
a result, most script files that run using TAPCIS can also be processed directly by Data 
Assistant.

Command Parameter Description
; -none- Comment
ECHO [E] text Echo the following text to the 

TTY screen (data is not sent to the port).
QUIT [Q] Quit, or abort, processing the 

script file
FILE [F] filename Execute another script at this 

point.  When the referenced script file has completed 
processing, resume processing this script at the next 
line.  Up to 8 scripts can be nested in this manner.

SEND [S] text Send the text to the 
communications port, and wait for the port to echo the 
text before continuing.

OUT [U] text Send the text to the 
communications port without waiting for the echo.  This
is normally used when the remote site does not echo 
back the text - as in a password.

WAIT [W] text Wait for the following text to be 
received from the communications port before 
continuing.

CAPTURE [C] filename Capture and store (append) all 
subsequent data from the port to the file identified as 
filename.

CAPTURE [C] Y Turn capture on and store (append) all 
subsequent data from the port to the end of the last 
capture file during this session.  If this is the first 
capture command in the script, the data is stored into 
file CAPTURE.DAT.

CAPTURE [C] N Turn capture off and close the capture 
file.



INPUT [I] Input data from the keyboard 
until the F7 key has been pressed.

KILL [K] filename Kill or delete the specified 
filename.

PAUSE [P] seconds Pause the number of specified seconds.
PORT [R] settings Configure the current port 

settings to the specified values.  settings represents 
the following parameter group:

baud,parity,data,stop

baud=110,300,600,1200,2400,4800,9600,19200

parity='N'(one),'E'(ven),'O'(dd),'M'(ark),'S'(pace)
data=5,6,7,8
stop=1,2

Example:
"PORT,9600,E,7,1

"

Special Control Characters can be used in script files by prefixing an alphabetic character 
with the caret character '^'.  As an example, to force a carriage return character to be sent at
the end of a 'S'end command, you would use the sequence '^M'.

Special Keywords can be used within the DAILY.TPL and HISTORY.TPL script template 
files.  These keywords make use of certain program information and allow you to perform 
limited tailoring of the script files used for automatic update.  The following are keywords and
their respective values which are supported by Data Assistant:

Keyword Description
&CIS_DAILY_PHONE& Replace with daily access CompuServe phone 

number.
&CIS_DAILY_USERID& Replace with daily access CompuServe User 

ID.
&CIS_DAILY_PASSWORD& Replace with daily access CompuServe password.
&CIS_HISTORY_PHONE& Replace with the historical access CompuServe phone 

number.
&CIS_HISTORY_USERID& Replace with historical access CompuServe User ID.
&CIS_HISTORY_PASSWORD& Replace with historical access CompuServe password.
&DAILY_CAPTURE& Replace with the daily access capture file 

name.
&HISTORY_CAPTURE& Replace with the historical access capture file 

name.
&HISTORY_SELECT& Replace with the historical access selection 

parameters for frequency ('D'aily, 'W'eekly, 'Y'early) and
the date range/count values from the "Historical Data 
Retrieval" dialog box.



&MODEM_INIT& Replace with the modem initialization 
string.

&MODEM_CONNECT& Replace with the modem connect recognition 
string.

&MODEM_NOCARRIER& Replace with the modem "no carrier" recognition string.
&MODEM_DIAL& Replace with the modem dial command 

string.
&MODEM_OK& Replace with the modem command ok 

string.
&SYMBOL[nn]& Replace with a list of one or more 

symbols separated by commas - where each 
subsequent request begins after the last symbol 
retrieved from a previous request. '[nn]' is an optional 
value for the number of symbols to replace (1-20).

BLOCKDAILY Begin a repeating set of script 
instructions based on the availability of daily symbols.  
The block of instructions MUST contain the use of the 
&SYMBOL[nn]& keyword.

BLOCKHISTORY Begin a repeating set of script 
instructions based on the availability of historical 
symbols to retrieve.  The block of instructions MUST 
contain the use of the &SYMBOL[nn]& keyword.

ENDBLOCK Identifies the end of a repeating block of
script instructions.

Example Script File
The following are example script files illustrating full and shorthand naming conventions that 
can be used to log onto CompuServe.

Full Script Commands
ECHO ********************
ECHO * CompuServe Login *
ECHO ********************
;
Send  ATDT 777-1234^M
Wait  CONNECT
Pause 2
Out   ^C
Wait  ID:
Send  70000,1000^M
Wait  Password:
Out   SECRET:PASSWORD^M
Wait  !

Shorthand Script Commands
E ********************
E * CompuServe Login *
E ********************
;
S  ATDT 777-1234^M
W  CONNECT



P 2
U ^C
W ID:
S 70000,1000^M
W Password:
U SECRET:PASSWORD^M
W !



Selecting Your Script File Editor

By default, Stable Data Assistant will invoke the Windows Notepad program whenever you 
choose to create or edit a script file.  You are, however, free to use any program to edit your 
script files by specifying the name of the program you want Data Assistant to run.

To specify your own script file editor:
1. Select Script Editor... from the Configure menu on the Main window.
2. Navigate and/or specify the name of the .PIF, .BAT, or .EXE executable Windows or 

DOS program you would like to use for creating or editing your script files.



About the Communications Terminal

The Communications Terminal window is used for all external communications between 
Data Assistant and a remote database or BBS.  For example, when Data Assistant is 
performing automatic update and retrieval, the Terminal window is activated for establishing 
a session with CompuServe.

Among the characteristics of the Terminal window are:
1. Script file processing (Data Assistant or user-written scripts).
2. ASCII communications only.  Binary transfer protocols such as Kermit, XModem, 

etc... are not supported.
3. User-selectable fonts for displaying the communication session.
4. Selectable communication parameters.
5. Resizable terminal window.
6. Single button press functionality for connecting, disconnecting, hanging up, capturing

ASCII session information, as well as script file loading and execution.

Commonly used functions have been made available through single button press operation. 
Along the top of the Terminal window are the following buttons:

Connect/Disconnect
Allows you to establish, or terminate, a connection between your computer and the modem. 
The button describes the action that will be taken when selected.  A disconnect has the side 
effect of closing an opened capture file.

When Connect is chosen, the modem "initialization" string is issued to the modem.  When 
Disconnect is chosen, the modem "disconnect" string is sent to the modem.

Hang Up
This button allows you to hang up the modem connection with a remote site - retaining the 
connection between your computer and the modem.  A hang up has the side effect of 
closing an opened capture file.

There are times when the communication session encounters errors and cannot 
complete successfully.  In these cases, you want to perform a hang up to physically drop
the connection with the remote site in order to save on connection costs.

Capture OFF/Capturing
This button provides you the ability to capture your communications session to a disk file.  
The button's text describes the current state of the capture process.

When you capture a communications session manually by pressing this button, all received 
data is appended to a file named CAPTURE.DAT in the directory containing your Data 
Assistant program files.

To turn of data capture, click on the Capturing button.  Note that a disconnect or hang up 
operation will automatically close an opened capture file.

Load...
Allows you to load a selected ASCII script file for processing by the Terminal window.



Execute
Executes the current script file.  This function can also be used to step through script file 
instructions if the automated processing of the script fails.

Cancel
Cancels and aborts execution of the current script.



9. Financial ASCII File Data Format

Stable Data Assistant provides maintenance facilities and automated file update features 
specifically for ASCII data files conforming to the following format and description.  This 
format (or a subset of this format) is directly supported by Stable Technical Graphs v1.11 
and above, as well as other third-party products including TechniFilter Plus v7.0 and 
spreadsheet applications such as Microsoft Excel and others.

Users of Stable Technical Graphs prior to version 1.11 should update to the 
latest release before using Data Assistant.  Stable Data Assistant does not 
maintain the record count entry found in the earlier data files.

The general format of the ASCII data file definition is as follows:
Format_String
Data_Record_1
Data_Record_2

-
-

Data_Record_N

Format_String is a description of the format of each data record contained in the file.  This 
string consists of two or more of the characters "DVOHLCI" (DC - or Date and Close - is the 
minimum required for any file), specifying both the sequence and type of data fields in each 
record.

D represents a Date field
This entry is actually one of the following; 'D' for daily data, 'W' for weekly data, 'Q' 
for quarterly data, 'M' for monthly data, or 'Y' for yearly data.

Additionally, a modifier can follow the date specifier character to identify a specific 
date format from the list below:

0 mm/dd/yy [optional]  (also the default if omitted)
1 mmddyy
2 yy/mm/dd
3 yymmdd
4 dd/mm/yy
5 ddmmyy
9 Serialized date format (Lotus-style)

V represents a Volume field (or short interest).
O represents an Open field.
H represents a High field.
L represents a Low field.
C represents a Close field.
I represents an Open Interest field.

Data_Record represents each ASCII record in the file.  All data records must be of the same
field sequence and contain identical types of fields.

Example ASCII Data Files
The following are examples of the contents of several different ASCII data files supported by



Stable Data Assistant and Stable Technical Graphs.  In each example, the use of the comma
to separate individual fields can be replaced by a tab (0x09) character in your actual data.

Market Index
DVHLC
1/2/92, 238169, 3184.7, 3119.86, 3172.41
1/3/92, 236228, 3221.38, 3156.31, 3201.48
1/6/92, 272785, 3230.32, 3166.59, 3200.13
1/7/92, 255148, 3224.73, 3165.25, 3204.83
1/8/92, 290369, 3245.53, 3164.58, 3203.94

The above illustrates an example of a file containing 5 data records. Each data record 
contains five fields identified by the "DVHLC" line.  The sequence of the fields is "D"aily Date
(in mm/dd/yy format), "V"olume, "H"igh, "L"ow, and "C"lose.  Note that 'D0' could have also 
been used to represent this date format.

Mutual Fund
W1C
010389, 14.28
011089, 14.69
011789, 14.67
012489, 14.90
013189, 15.28

The above illustrates a file containing 5 data records. Each data record contains two fields 
identified by the "W1C" line.  The sequence of the fields is "W"eekly Date (in mmddyy form) 
and "C"lose.  Decimal values are used for numerics.

Stock
D3VHLC
900102, 3913, 52 7/8, 52 3/8, 52 3/8
900103, 3628, 53 3/8, 52 1/8, 53 3/8
900104, 5057, 54 1/4, 53 1/4, 53 7/8
900105, 4624, 53 5/8, 53 1/8, 53 3/8
900106, 5203, 53 1/4, 51 5/8, 52 3/4

The above illustrates a file containing 5 data records. Each data record contains five fields 
identified by the "D3VHLC" line.  The sequence of the fields is "D"aily Date (in yymmdd 
form), "V"olume, "H"igh, "L"ow, and "C"lose.  Volume information is represented as a 
decimal value, while fractional values are used for all others.



10. Registration Order Form

To become a licensed user of Stable Data Assistant, please return this registration 
form along with your check or postal money order drawn on U.S. funds only, and mail to:

WINTERRA Software Group
P.O. Box  4106

Highlands Ranch, CO    80126
Voice/Fax: (303) 470-6323

Once registered, you will receive; the latest version of this product, a laser-printed User's
Manual, an offer for a free Introductory Membership to CompuServe (including a $15 Usage

Credit), future upgrade notifications, and technical product support.

Stable Data Assistant is only $39.95 for a single user license.
Site licenses are also available - see file SITELICE.DOC.

Name: _____________________________________________________
Company: _____________________________________________________
Address: _____________________________________________________
City: ________________________________________
State: _________________
Zip: _________________

Phone: (________)__________________________
Fax: (________)__________________________

Date: __________________ CompuServe ID: __________________

Format: ____ 3 1/2" 720KB ____ 5 1/4" 360KB

Quantity: ____ Stable Data Assistant @$39.95 $____________

Shipping/Handling and Customs
____ U.S. @$  4.00 $____________
____ Canada/Mexico @$  6.00 $____________
____ International @$12.00 $____________

    TOTAL $____________

Credit Card Customers
Contact WINTERRA Software Group for the availability of accepting credit card orders.

da-rf002


